Cargo
  1. Cargo
  2. CARGO-875

java.lang.StringIndexOutOfBoundsException: String index out of range: 5 at createJBossFilterChain(JBoss51xStandaloneLocalConfiguration.java:56)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.5
    • Fix Version/s: 1.0.6
    • Component/s: JBoss
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      I'm getting this exception. I guess it is my fault, but it shouldn't throw this exception.

      Caused by: org.codehaus.cargo.container.ContainerException: Failed to create a JBoss 51x standalone configuration
      at org.codehaus.cargo.container.spi.configuration.AbstractLocalConfiguration.configure(AbstractLocalConfiguration.java:194)
      at org.codehaus.cargo.container.spi.configuration.AbstractStandaloneLocalConfiguration.configure(AbstractStandaloneLocalConfiguration.java:75)
      at org.codehaus.cargo.maven2.ConfigureMojo.doExecute(ConfigureMojo.java:64)
      at org.codehaus.cargo.maven2.AbstractCargoMojo.execute(AbstractCargoMojo.java:268)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:107)
      ... 20 more
      Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: 5
      at java.lang.String.substring(String.java:1934)
      at org.codehaus.cargo.container.jboss.JBossStandaloneLocalConfiguration.createJBossFilterChain(JBossStandaloneLocalConfiguration.java:276)
      at org.codehaus.cargo.container.jboss.JBoss51xStandaloneLocalConfiguration.createJBossFilterChain(JBoss51xStandaloneLocalConfiguration.java:56)
      at org.codehaus.cargo.container.jboss.JBoss51xStandaloneLocalConfiguration.doConfigure(JBoss51xStandaloneLocalConfiguration.java:87)
      at org.codehaus.cargo.container.spi.configuration.AbstractLocalConfiguration.configure(AbstractLocalConfiguration.java:190)
      ... 24 more

        Activity

        Jochen Stiepel added a comment -

        There was a "/" missing after the "$

        {basedir}". My fault, but would be nice to get a better error message. Something like: "could not parse <file> tag" or similar.

        <configfile>
        <file>${basedir}

        ../tools/jboss-files/abc_ds-ds.xml</file>
        <todir>deploy</todir>
        </configfile>

        Savas Ali Tokmen added a comment -

        Committed revision 2587.

        Thank you


          People

          • Assignee:
            Savas Ali Tokmen
            Reporter:
            Jochen Stiepel
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: