Cargo
  1. Cargo
  2. CARGO-499

Deploying war with relative path under orion1x fails

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.9
    • Component/s: Orion
    • Labels:
      None
    • Environment:
      Windows XP / Linux
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      The test samples/java/target/orion1x/installed/WarCapabilityContainerTest/testDeployWarDefinedWithRelativePath fails with a file not found exception:
      Caused by: java.io.FileNotFoundException: samples/java/target/orion1x/installed/WarCapabilityContainerTest/testDeployWarDefinedWithRelativePath/simple.war (No such file or directory

      <testcase time="1.193" name="testDeployWarDefinedWithRelativePath ">
      <error type="org.codehaus.cargo.container.ContainerException" message="Failed to create a Orion 1.x standalone configuration">org.codehaus.cargo.container.ContainerException: Failed to create a Orion 1.x standalone configuration
      at org.codehaus.cargo.container.spi.configuration.AbstractLocalConfiguration.configure(AbstractLocalConfiguration.java:165)
      at org.codehaus.cargo.container.spi.AbstractLocalContainer.start(AbstractLocalContainer.java:144)
      at org.codehaus.cargo.sample.java.WarCapabilityContainerTest.testDeployWarDefinedWithRelativePath(WarCapabilityContainerTest.java:88)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at junit.framework.TestCase.runTest(TestCase.java:154)
      at junit.framework.TestCase.runBare(TestCase.java:127)
      at junit.framework.TestResult$1.protect(TestResult.java:106)
      at junit.framework.TestResult.runProtected(TestResult.java:124)
      at junit.framework.TestResult.run(TestResult.java:109)
      at junit.framework.TestCase.run(TestCase.java:118)
      at junit.framework.TestSuite.runTest(TestSuite.java:208)
      at junit.framework.TestSuite.run(TestSuite.java:203)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.maven.surefire.battery.JUnitBattery.executeJUnit(JUnitBattery.java:242)
      at org.apache.maven.surefire.battery.JUnitBattery.execute(JUnitBattery.java:216)
      at org.apache.maven.surefire.Surefire.executeBattery(Surefire.java:215)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:126)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:87)
      at org.apache.maven.surefire.Surefire.run(Surefire.java:63)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.maven.surefire.SurefireBooter.main(SurefireBooter.java:785)
      Caused by: java.io.FileNotFoundException: samples/java/target/orion1x/installed/WarCapabilityContainerTest/testDeployWarDefinedWithRelativePath/simple.war (No such file or directory
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:106)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:394)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:295)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:275)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:260)
      at org.codehaus.cargo.container.orion.internal.AbstractOrionStandaloneLocalConfiguration.doConfigure(AbstractOrionStandaloneLocalConfiguration.java:138)
      at org.codehaus.cargo.container.spi.configuration.AbstractLocalConfiguration.configure(AbstractLocalConfiguration.java:161)
      ... 29 more
      java.io.FileNotFoundException: samples/java/target/orion1x/installed/WarCapabilityContainerTest/testDeployWarDefinedWithRelativePath/simple.war (No such file or directory)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:106)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:394)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:295)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:275)
      at org.apache.tools.ant.util.FileUtils.copyFile(FileUtils.java:260)
      at org.codehaus.cargo.container.orion.internal.AbstractOrionStandaloneLocalConfiguration.doConfigure(AbstractOrionStandaloneLocalConfiguration.java:138)
      at org.codehaus.cargo.container.spi.configuration.AbstractLocalConfiguration.configure(AbstractLocalConfiguration.java:161)
      at org.codehaus.cargo.container.spi.AbstractLocalContainer.start(AbstractLocalContainer.java:144)
      at org.codehaus.cargo.sample.java.WarCapabilityContainerTest.testDeployWarDefinedWithRelativePath(WarCapabilityContainerTest.java:88)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at junit.framework.TestCase.runTest(TestCase.java:154)
      at junit.framework.TestCase.runBare(TestCase.java:127)
      at junit.framework.TestResult$1.protect(TestResult.java:106)
      at junit.framework.TestResult.runProtected(TestResult.java:124)
      at junit.framework.TestResult.run(TestResult.java:109)
      at junit.framework.TestCase.run(TestCase.java:118)
      at junit.framework.TestSuite.runTest(TestSuite.java:208)
      at junit.framework.TestSuite.run(TestSuite.java:203)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

        Activity

        David J. M. Karlsen added a comment -

        Fixes the resolving of the deployable filename, which might indirectly be triggered by not being able to set the working directory while forking tests in surefire: http://jira.codehaus.org/browse/SUREFIRE-295.

        Tests still have the same problems as in http://jira.codehaus.org/browse/CARGO-488 after fixing this concrete issue.


          People

          • Assignee:
            David J. M. Karlsen
            Reporter:
            David J. M. Karlsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: