Cargo
  1. Cargo
  2. CARGO-490

Deploying war with relative filename fails on tomcat3x

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: Tomcat
    • Labels:
      None
    • Environment:
      JDK 1.4.2, Windows XP
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Tomcat3x test fails when using relative path when pointing to a deployable war-archive, throwing a file not found exception.

      running mvn -Dcargo.containers=3x clean test in samples/java fails with a

      "
      Caused by: java.io.FileNotFoundException: java\target\tomcat3x\installed\WarCapabilityContainerTest\testDeployWarDefinedWithRelativePath\simple.war (The system cannot find the path specified) "

        Activity

        David J. M. Karlsen added a comment -

        r1360 in svn fixes the issue so that deployables declared with relative paths are deployed correctly instead of throwing a FileNotFoundException

        Vincent Massol added a comment -

        Reopen as we need to fix the issue title and description. They need to be user-oriented as otherwise no user will understand what this means and how it solves an issue they have!

        Vincent Massol added a comment -

        David,

        Are you sure that it doesn't work? I'm asking because we have a test in samples/java for verifying exactly that and AFAIK it was passing! The test is named testDeployWarDefinedWithRelativePath()

        Thanks

        Vincent Massol added a comment -

        oops just realized that this issue was about fixing that test for Tomcat 3x... (stupid me!)

        Vincent Massol added a comment -

        I think this issue is solved so closing it


          People

          • Assignee:
            David J. M. Karlsen
            Reporter:
            David J. M. Karlsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: