Cargo
  1. Cargo
  2. CARGO-489

Tomcat 5.x doesn't build in samples/java with the Maven2 build

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: Build
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Just run "mvn install -Ptomcat5x" in samples/java to reproduce

        Activity

        David J. M. Karlsen added a comment -

        using surefire 2.3-SNAPSHOT and setting forkMode=once, this reduces the testfailures down to
        testExpandedWarWithContextXmlFile
        failing on:

        Caused by: org.xml.sax.SAXParseException: Relative URI "sample/tomcat-context.dtd"; can not be resolved without a base URI.

        Basing the tests on a snapshot version is probably the best we can do at this point - but not optimal. We can discuss this on the dev-list.

        David J. M. Karlsen added a comment -

        All issues have now been fixed (Se svn commits).
        Related to either relative pathname errors, or addition of xml-apis, xalan and xerces to the surefire classpath.


          People

          • Assignee:
            David J. M. Karlsen
            Reporter:
            Vincent Massol
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: