Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9
    • Component/s: Jetty
    • Labels:
      None
    • Environment:
      Windows XP and Debian GNU/Linux
    • Complexity:
      Intermediate
    • Tested on JDKs:
      1.4 / 1.6
    • Number of attachments :
      1

      Description

      Updates for Jetty 6.1.0 compability

      1. CARGO-474.patch
        53 kB
        David J. M. Karlsen

        Issue Links

          Activity

          Hide
          Jan Bartel added a comment -

          I've checked in some changes to bring cargo more up to date with the jetty6 API.

          I have not yet been able to test these, so if David or someone else has some time, that would be great.

          There is still some more work that could be done. The javabeans properties that are set up on the Jetty6xLocalDeployer should be moved instead into a Jetty6xWAR class to allow the user to supply custom configuration params for the war at deploytime. If there are any questions please ping me.

          Show
          Jan Bartel added a comment - I've checked in some changes to bring cargo more up to date with the jetty6 API. I have not yet been able to test these, so if David or someone else has some time, that would be great. There is still some more work that could be done. The javabeans properties that are set up on the Jetty6xLocalDeployer should be moved instead into a Jetty6xWAR class to allow the user to supply custom configuration params for the war at deploytime. If there are any questions please ping me.
          Hide
          David J. M. Karlsen added a comment -

          Tested with m1 and m2 builds under jdk 1.4 - works fine

          Show
          David J. M. Karlsen added a comment - Tested with m1 and m2 builds under jdk 1.4 - works fine
          Hide
          David J. M. Karlsen added a comment -

          Patch to use jsp-api 2.1 in jdk >= 1.5, else jsp-api-2.0, addressing #1 in http://www.nabble.com/forum/ViewPost.jtp?post=8280340&framed=y

          Show
          David J. M. Karlsen added a comment - Patch to use jsp-api 2.1 in jdk >= 1.5, else jsp-api-2.0, addressing #1 in http://www.nabble.com/forum/ViewPost.jtp?post=8280340&framed=y
          Hide
          Vincent Massol added a comment -

          David,

          I think we should close this issue as Cargo does uspport Jetty 6.1 now. We should open new issues for adding support for the Jetty6xWAR stuff that Jan was mentioning and for the ability to supoprt JSP 2.1

          Let me know if you want to do this.

          I'd like to release Cargo 0.9 today or tomorrow and we need this issue closed for this as Jetty 6.1 support is already there and we don't need the improvements for 0.9. They can wait.

          Thanks
          -Vincent

          Show
          Vincent Massol added a comment - David, I think we should close this issue as Cargo does uspport Jetty 6.1 now. We should open new issues for adding support for the Jetty6xWAR stuff that Jan was mentioning and for the ability to supoprt JSP 2.1 Let me know if you want to do this. I'd like to release Cargo 0.9 today or tomorrow and we need this issue closed for this as Jetty 6.1 support is already there and we don't need the improvements for 0.9. They can wait. Thanks -Vincent
          Hide
          David J. M. Karlsen added a comment -

          Closing as requested, new issue raised for the remaing enhancements: http://jira.codehaus.org/browse/CARGO-483

          Show
          David J. M. Karlsen added a comment - Closing as requested, new issue raised for the remaing enhancements: http://jira.codehaus.org/browse/CARGO-483

            People

            • Assignee:
              Jan Bartel
              Reporter:
              David J. M. Karlsen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: