BTM
  1. BTM
  2. BTM-63

ACCESSIBLE connection closed due to Recoverer failure (nothing prevents recoverer from running twice in parallel)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.3
    • Fix Version/s: 2.0.0
    • Labels:
      None
    • Environment:
      SUSE Linux Enterprise Server 11 (x86_64)
    • Patch Submitted:
      Yes
    • Number of attachments :
      2

      Description

      By the look of things it seems the following sequence of events happens:

      • Recoverer kicks in and attempt to process data source oracle-asm (aimprod88_Other.log.1 - 05 Jan 2010 23:22:53,285)
      • an attempt is made to change a AbstractXAStatefulHolder's state from IN_POOL to IN_POOL (aimprod88_Other.log.1 - 05 Jan 2010 23:22:53,299)
      • an exception is thrown from AbstractXAStatefulHolder and the recovery of oracle-asm fails; oracle-asm iss marked as "failed" (aimprod88_Other.log.1 - 05 Jan 2010 23:22:53,300)
      • DspThread-11-ContractWorkUnit attempts to acquire a connection from oracle-asm and notices oracle-asm was marked as "failed" (aimprod88_Other.log.1 - 05 Jan 2010 23:22:53,355)
      • DspThread-11-ContractWorkUnit closes the XAPool which includes connection T4CXAConnection@5917afa8 which is currently in use (state ACCESSIBLE) (aimprod88_Other.log.1 - 05 Jan 2010 23:22:53,371)
      • DspThread-17-ContractWorkUnit05 gets SQLException when trying to use closed connection T4CXAConnection@5917afa8 (aimprod88_ContractWorkUnit.log - Jan 2010 23:22:59,579)
      1. btm.tar.bz2
        228 kB
        Ben Daici
      2. emergency_fox_for_BTM-63.patch
        2 kB
        Ludovic Orban

        Activity

        Ludovic Orban added a comment -

        quick patch which prevents the recoverer from being reentered.

        Ben Daici added a comment -

        Not sure about the DB locks but it's possible, at least in theory. We do have long running transactions that lock resources. However, by looking at the recovery durations, it looks as though the recovery takes about a minute or so so I am not sure if locking plays any role.
        Thanks for the patch, we will test it and let you know how it went.

        Ludovic Orban added a comment -

        Emergency patch has been committed to the 1.3.3 branch. I'm waiting for an acknowledge of the reporter that the issue is fixed before applying an improved version of that fix on the trunk.

        Ben Daici added a comment -

        I have not been able to reproduce the issue since the patch was applied so I am inclined to believe the fix has resolved it.

        Ludovic Orban added a comment -

        Thanks for the report, Ben.

        I'm now going to port the patch to the trunk.


          People

          • Assignee:
            Ludovic Orban
            Reporter:
            Ben Daici
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: