BTM
  1. BTM
  2. BTM-2

error not reported when XAResource.recover() call fails

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.2
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Recoverer is supposed to catch exception thrown by XAResource.recover() calls and report them. This does not happen anymore.

        Activity

        Ludovic Orban added a comment -

        This is caused by this change: http://svn.btm.codehaus.org/browse/btm/trunk/src/bitronix/tm/recovery/Recoverer.java?r1=42&r2=72

        The implementation has changed because Informix improperly chokes on successive XAResource.recover() calls. Unfortunately, exceptions are now catched and reported as debug logs.

        Ludovic Orban added a comment -

        Fixed in trunk.


          People

          • Assignee:
            Ludovic Orban
            Reporter:
            Ludovic Orban
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: