BTM
  1. BTM
  2. BTM-19

No effect by setting auto-commit to false on LrcConnectionHandle

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Labels:
      None
    • Environment:
      platform independent
    • Number of attachments :
      0

      Description

      Setting auto-commit to false an a LrcXADataSource (no xa-context) doesn't take effect.

      Looking into the code the cause might lay in method LrcConnectionHandle->setAutoCommit where the call isn't forwarded to the delegate.

        Activity

        Ludovic Orban added a comment -

        This is clearly a bug that managed to remain unnoticed for some time now. Will be fixed in 1.3.

        Ludovic Orban added a comment -

        Fixed in trunk.


          People

          • Assignee:
            Ludovic Orban
            Reporter:
            Michael
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: