Maven Archetype
  1. Maven Archetype
  2. ARCHETYPE-282

When reading the archetype-metadata.xml file, would be helpful to know if the XML was badly formed

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0-alpha-4
    • Fix Version/s: 2.0
    • Component/s: Generator
    • Labels:
      None
    • Environment:
      Windows, but affects all envs
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      If archetype-metadata.xml is malformed, say with a module element which is unclosed (missing slash), there is no error message displayed in the log output, even with the debug(-X) parameter set.

      The DefaultArchetypeArtifactManager class contains methods which catch exceptions but do not log the problem. The problem is just silently ignored. I've created a patch file to log the problem at WARN level so that anyone who has a problem can see why it occured.

        Activity

        Herve Boutemy added a comment -

        code simplification done in r1004061


          People

          • Assignee:
            Herve Boutemy
            Reporter:
            Chris Melikian
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: