Maven Archetype
  1. Maven Archetype
  2. ARCHETYPE-270

RemoteCatalogArchetypeDataSource leaves open wagon connection when archetype catalog retrieval fails

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-alpha-5
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      If you have an archetype catalog entry with a bad url/archetype catalog file (the file isn't there), the RemoteArchetypeCatalogDataSource blows up when it tries to get the file over wagon. After it blows up, the wagon connection is not disconnected - as a result, there is an orphaned job in progress 'Updating indexes: 0%' (which is also badly named). The problem is on line 88:

      wagon.connect( wagonRepository );

      (get fails) >>>>>>> wagon.get( fileName , catalog );

      wagon.disconnect();
      return readCatalog( new FileReader( catalog ) );

      I assume it should disconnect in the catch() block below

        Activity

        Benjamin Bentmann added a comment -

        Fixed in r833730.


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Dan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: