Activiti
  1. Activiti
  2. ACT-583

Processes are not found in the bar file, if they are below root

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.1
    • Fix Version/s: 5.9
    • Component/s: None
    • Labels:
      None
    • Environment:
      GlassFish 3.1-b36
      Apache Felix 3.0.7
      Apache Aries 0.2-incubation (blueprint + transaction)
    • Number of attachments :
      1

      Description

      The process is not found in a bar file with the following content:

      • test.bpmn20.xml
        But if the process is put into a directory, it is found; e.g. in a bar file with the following content:
      • test/test.bpmn20.xml

      Log:

      org.activiti.osgi.Extender;MethodName=checkBundle;|Scanning bundle {} for activiti process
      org.activiti.osgi.Extender;MethodName=checkBundle;|No activiti process found in bundle {}
      

        Activity

        Joram Barrez added a comment -

        Is this an issue in an OSGI environment only?
        Because I cant reproduce it in the regular engine deploy ways.

        Capacia added a comment -

        Yes, this seems to be an issue only in the OSGI environment.

        Laszlo Hordos added a comment - - edited

        This simple patch fixes the problem and now the processes are found in the bar file. I tested both case when the process is under the root or other sub directory.
        This transformer produce and empty string and the fix adds "/" instead.
        trunk/modules/activiti-osgi/src/main/java/org/activiti/osgi/BarTransformer.java

        The Extender#checkBundle calls the HeaderParser#parseHeader and it does not parse an empty string

        Tijs Rademakers added a comment -

        Patch applied, thanks Laszlo


          People

          • Assignee:
            Tijs Rademakers
            Reporter:
            Capacia
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: