Activiti
  1. Activiti
  2. ACT-303

Table "ACT_RE_DEPLOYMENT" not found.

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.0.rc1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The following error happened when starting Activiti Engine with empty h2 database by Spring ProcessEngineFactoryBean with auto resources deployment enabled:
      org.apache.ibatis.exceptions.PersistenceException:

          1. Error querying database. Cause: org.h2.jdbc.JdbcSQLException: Table "ACT_RE_DEPLOYMENT" not found; SQL statement:
            select * from ACT_RE_DEPLOYMENT D where NAME_=? order by D.DEPLOY_TIME_ asc [42102-132]
            at org.h2.message.DbException.getJdbcSQLException(DbException.java:316)
            at org.h2.message.DbException.get(DbException.java:167)
            at org.h2.message.DbException.get(DbException.java:144)
            at org.h2.command.Parser.readTableOrView(Parser.java:4347)
            at org.h2.command.Parser.readTableFilter(Parser.java:1001)
            at org.h2.command.Parser.parseSelectSimpleFromPart(Parser.java:1529)
            at org.h2.command.Parser.parseSelectSimple(Parser.java:1626)
            at org.h2.command.Parser.parseSelectSub(Parser.java:1523)
            at org.h2.command.Parser.parseSelectUnion(Parser.java:1368)
            at org.h2.command.Parser.parseSelect(Parser.java:1356)
            at org.h2.command.Parser.parsePrepared(Parser.java:395)
            at org.h2.command.Parser.parse(Parser.java:278)
            at org.h2.command.Parser.parse(Parser.java:250)
            at org.h2.command.Parser.prepareCommand(Parser.java:222)
            at org.h2.engine.Session.prepareLocal(Session.java:420)
            at org.h2.server.TcpServerThread.process(TcpServerThread.java:224)
            at org.h2.server.TcpServerThread.run(TcpServerThread.java:135)
            at java.lang.Thread.run(Thread.java:619)
          1. The error may exist in org/activiti/db/ibatis/repository.mapping.xml
          2. The error may involve org.activiti.persistence.selectDeploymentsByName
          3. The error occurred while executing a query
          4. SQL: select * from ACT_RE_DEPLOYMENT D where NAME_=? order by D.DEPLOY_TIME_ asc
          5. Cause: org.h2.jdbc.JdbcSQLException: Table "ACT_RE_DEPLOYMENT" not found; SQL statement:
            select * from ACT_RE_DEPLOYMENT D where NAME_=? order by D.DEPLOY_TIME_ asc [42102-132]
            at org.h2.message.DbException.getJdbcSQLException(DbException.java:316)
            at org.h2.message.DbException.get(DbException.java:167)
            at org.h2.message.DbException.get(DbException.java:144)
            at org.h2.command.Parser.readTableOrView(Parser.java:4347)
            at org.h2.command.Parser.readTableFilter(Parser.java:1001)
            at org.h2.command.Parser.parseSelectSimpleFromPart(Parser.java:1529)
            at org.h2.command.Parser.parseSelectSimple(Parser.java:1626)
            at org.h2.command.Parser.parseSelectSub(Parser.java:1523)
            at org.h2.command.Parser.parseSelectUnion(Parser.java:1368)
            at org.h2.command.Parser.parseSelect(Parser.java:1356)
            at org.h2.command.Parser.parsePrepared(Parser.java:395)
            at org.h2.command.Parser.parse(Parser.java:278)
            at org.h2.command.Parser.parse(Parser.java:250)
            at org.h2.command.Parser.prepareCommand(Parser.java:222)
            at org.h2.engine.Session.prepareLocal(Session.java:420)
            at org.h2.server.TcpServerThread.process(TcpServerThread.java:224)
            at org.h2.server.TcpServerThread.run(TcpServerThread.java:135)
            at java.lang.Thread.run(Thread.java:619)

      at org.apache.ibatis.exceptions.ExceptionFactory.wrapException(ExceptionFactory.java:8)
      at org.apache.ibatis.session.defaults.DefaultSqlSession.selectList(DefaultSqlSession.java:61)
      at org.activiti.engine.impl.db.DbSqlSession.selectList(DbSqlSession.java:152)
      at org.activiti.engine.impl.db.DbRepositorySession.findLatestDeploymentByName(DbRepositorySession.java:184)
      at org.activiti.engine.impl.cmd.DeployCmd.execute(DeployCmd.java:45)
      at org.activiti.engine.impl.cmd.DeployCmd.execute(DeployCmd.java:30)
      at org.activiti.engine.impl.interceptor.CommandExecutorImpl.execute(CommandExecutorImpl.java:22)
      at org.activiti.engine.impl.interceptor.CommandContextInterceptor.execute(CommandContextInterceptor.java:36)
      at org.activiti.spring.SpringTransactionInterceptor$1.doInTransaction(SpringTransactionInterceptor.java:42)
      at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:130)
      at org.activiti.spring.SpringTransactionInterceptor.execute(SpringTransactionInterceptor.java:40)
      at org.activiti.engine.impl.interceptor.LogInterceptor.execute(LogInterceptor.java:33)
      at org.activiti.engine.impl.RepositoryServiceImpl.deploy(RepositoryServiceImpl.java:43)
      at org.activiti.engine.impl.repository.DeploymentBuilderImpl.deploy(DeploymentBuilderImpl.java:101)
      at org.activiti.spring.ProcessEngineFactoryBean.autoDeployResources(ProcessEngineFactoryBean.java:168)
      at org.activiti.spring.ProcessEngineFactoryBean.getObject(ProcessEngineFactoryBean.java:86)
      at org.activiti.spring.ProcessEngineFactoryBean.getObject(ProcessEngineFactoryBean.java:54)

        Activity

        Lim Chee Kin added a comment -

        Forgot to mentioned dbSchemaStrategy = "create-drop"

        Joram Barrez added a comment -

        Did you specify the databaseType on the ProcessEngineFactoryBean ?

        Lim Chee Kin added a comment -

        Yes, I did. databaseType="h2"

        Tom Baeyens added a comment -

        joram says he thinks he already fixed this. joram will review.

        Lim Chee Kin added a comment -

        Hi Joram, Do make sure that you have some process definition files in auto-deploy directory configured in deploymentResources property when you try to simulate this issue.

        Joram Barrez added a comment -

        Could not reproduce on trunk, probably fixed by the configuration refactoring of Tom.

        Added test to test suite to avoid regression.

        Lim Chee Kin added a comment -

        Thanks. I will re-test it


          People

          • Assignee:
            Joram Barrez
            Reporter:
            Lim Chee Kin
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: