Activiti
  1. Activiti
  2. ACT-1514

NullPointerException in create new Diagram dialog

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.11
    • Fix Version/s: 5.11
    • Component/s: Designer
    • Labels:
      None
    • Environment:
      STS 2.9.2 (i.e. 3.7.2)
      eclipse 3.8.1
    • Number of attachments :
      0

      Description

      When trying to create a new diagram with the new diagram wizard, the next button does not work.
      On the console, I see the following exception:

      java.lang.NullPointerException
      at org.activiti.designer.eclipse.ui.wizard.diagram.CreateDefaultActivitiDiagramWizard.getDiagramFile(CreateDefaultActivitiDiagramWizard.java:61)
      at org.activiti.designer.eclipse.ui.wizard.diagram.CreateDefaultActivitiDiagramWizard.canCreateDiagramFile(CreateDefaultActivitiDiagramWizard.java:46)
      at org.activiti.designer.eclipse.ui.wizard.diagram.CreateDefaultActivitiDiagramWizard.canFinish(CreateDefaultActivitiDiagramWizard.java:42)
      at org.eclipse.jface.wizard.WizardDialog.updateButtons(WizardDialog.java:1344)

        Activity

        Tijs Rademakers added a comment -

        I couldn't reproduce this. Does this error also occur for you on a default Indigo Java Eclipse IDE?
        Did you specify a name for the process and a folder in the Activiti project?

        Heinz-Dieter Conradi added a comment -

        My second try was on a vanilla eclipse 3.8.1 installation without any other plugin.
        I used one existing project of mine and then did: File -> New -> Other -> Activiti Diagram -> accepted the given diagram name -> Next -> Hang

        However, with your comment I went over the process again and found, that indeed the parent folder has not been chosen.

        I.e. the bug is rather, that one should not be able to leave the first page of the wizard and that omission should be highlighted.

        Thanks, Heinz-Dieter

        Tijs Rademakers added a comment -

        Fixed, will release a 5.11.2 today


          People

          • Assignee:
            Tijs Rademakers
            Reporter:
            Heinz-Dieter Conradi
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: