Activiti
  1. Activiti
  2. ACT-1461

The startableByUser method on the ProcessDefinitionQuery object does not return process definitions records for "candidate starter groups" when a custom session factory has been implemented

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 5.10
    • Fix Version/s: 5.11
    • Component/s: Engine
    • Labels:
      None
    • Number of attachments :
      0

      Description

      After customizing the session factory for LDAP integration the method startableByUser on the ProcessDefinitionQuery object does not return anything for users that are in the referenced group. It looks like this functionality is dependent on SQL. In our case the ACT_ID_MEMBERSHIP table is empty as we are dependent on LDAP.

      Generated SQL:
      SELECT distinct PD.*
      FROM ACT_RE_PROCDEF PD WHERE
      ( exists ( SELECT ID_
      FROM ACT_RU_IDENTITYLINK IDN
      WHERE IDN.PROC_DEF_ID_ = PD.ID_
      AND IDN.USER_ID_ = 'USER-A'
      ) OR
      exists ( SELECT IDN.ID_
      FROM ACT_RU_IDENTITYLINK IDN, ACT_ID_MEMBERSHIP MBMR
      WHERE IDN.PROC_DEF_ID_ = PD.ID_
      AND MBMR.USER_ID_ = 'USER-A' and IDN.GROUP_ID_ = MBMR.GROUP_ID_
      )
      )

        Activity

        Tijs Rademakers added a comment -

        Duplicate of ACT-1416, which is now fixed


          People

          • Assignee:
            Tijs Rademakers
            Reporter:
            Robert McKinnon
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: