Activiti
  1. Activiti
  2. ACT-1111

"null" exception in activiti designer when creating BPMN file

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.8
    • Fix Version/s: 5.9
    • Component/s: Designer
    • Environment:
      Activiti 5.8, Eclipse SDK 3.6.2, Windows XP, JDK 1.6.025
    • Testcase included:
      yes
    • Number of attachments :
      2

      Description

      When I open the attached file in Designer, it fails to create the BPMN file.
      2 lines are created in the problems view :
      Marshalling to Activiti BPMN 2.0 format was skipped because validation of the diagram failed.
      An exception occurred while creating the BPMN 2.0 XML: null

      This is not helpfull at all to fix the diagram !

        Activity

        Heiko Kopp added a comment -

        Hey Michel,

        I'm checking on this today in the evening. It definitely should not come out as "null" in the error.

        Heiko Kopp added a comment -

        Patch to create better error output, in case sourceRef and/or targetRef IDs are not valid within *.activiti-Files. Most probably not relevant merge of files in progress for Designer 5.9

        Heiko Kopp added a comment -

        Hello Michel,

        I've added some better error output to the Designer to check what the problem is. Actually your activiti-File contains alot of "invisible" (invalid) pictogram data, e.g. double flows, etc.

        If you for example see something like this

        <flowElements xsi:type="bpmn2:EndEvent" id="endevent3" name="End" incoming="flow8 flow13Def"/>

        it is most probably an error, as "flow8" is incoming but not outgoing. My corrected patch will produce error messages like:

        An exception occurred while creating the BPMN 2.0 XML: No valid sourceRef ID for sequence flow 'flow8' found.

        This helps indeed, but we are currently on our way to merge the activiti and the bpmn20.xml-files, therefore I would suggest you see that you remove the double flows and check your activiti-file for any invisible elements and remove them too. Afterwards the BPMN xml should be generated again.

        Michel Daviot added a comment -

        Thanks for your feedback !
        FYI, the activiti file was created using only the Designer plugin, I didn't mess manually with the xml source.
        I'll update the xml manually with your advice, no problem.

        Regards
        Michel

        Tijs Rademakers added a comment -

        This should not occur anymore with the 1 model approach

        Michel Daviot added a comment -

        Sorry, but in my opinion this is not fixed in 5.9 since 5.9 release does not include (yet ?) an update of the Activiti Designer plugin for Eclipse.
        I would like this issue to be kept open for now.

        Tijs Rademakers added a comment -

        The Activiti Designer 5.9 release will be a bit later than the Activiti 5.9 release. We expect to release Activiti Designer 5.9 within a week, therefore I resolved the issue for 5.9.


          People

          • Assignee:
            Tijs Rademakers
            Reporter:
            Michel Daviot
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: